Skip to content
Snippets Groups Projects
ForestStructures.nix 1013 B
{ mkDerivation, QuickCheck, base, bifunctors, containers, criterion
, fgl, lens, lib, tasty, tasty-quickcheck, tasty-th
, unordered-containers, vector, vector-th-unbox
}:
mkDerivation {
  pname = "ForestStructures";
  version = "0.0.1.0";
  sha256 = "7c5b4a7b78178396152c0dc24d966b55557f5bdaaf0cfa24ee71c9cb006315c2";
  isLibrary = true;
  isExecutable = false;
  enableSeparateDataOutput = false;
  libraryHaskellDepends = [
    base bifunctors containers fgl lens QuickCheck unordered-containers
    vector vector-th-unbox
  ];
  testHaskellDepends = [
    base containers QuickCheck tasty tasty-quickcheck tasty-th vector
  ];
  benchmarkHaskellDepends = [ base criterion ];
  enableLibraryProfiling = true;
  enableExecutableProfiling = true;
  doHaddock = true;
  jailbreak = true;
  doCheck = false;
  doBenchmark = false;
  hyperlinkSource = false;
  homepage = "https://github.com/choener/ForestStructures";
  description = "Tree- and forest structures";
  license = lib.licenses.bsd3;
  broken = false;
}